Repeated Outlook 2007 Password Prompts with Hosted Exchange Account

A couple of weeks ago, I moved the remainder of my sites from 1&1 to Servage (that link will get you an extra 75 GB of storage) for my personal Web hosting, and among them was my wife’s domain. This domain is connected to a hosted Exchange account (4smartphone), and part of the move was setting up a the autodiscovery domain so Outlook can self-configure. After the DNS changes were made, something strange started happening with Outlook on both my wife’s desktop and netbook: it would repeatedly prompt for the password. No password changes were made, and strangely enough, she could send and receive email even though every few minutes it would prompt her for the password. 4smartphone tech support wasn’t very helpful; they claimed it was an Outlook problem. After some sleuthing around, convinced that it was related to the DNS changes I made, I realized my mistake: I had created the autodiscover CNAME entry pointing at the wrong server name (EXCH016 instead of EXCH015). After updating the DNS record, within a few hours the problem was fixed – no more repeated password prompts in Outlook. So if you happen to have the same sort of problem, double-check your DNS records…

  • Hey Jason, do you have any information on how to set up the CNAME for a hosted Exchange account? We’ve got one for one of our domains and I’ve always wanted to setup the autodiscovery, but have no idea how to do it.

  • Perry,
    You’d set up the CNAME in whatever you use for DNS controls….that’s typically your Web host, or possibly your domain host if you’re using their DNS.

  • and I’d set it up for autodiscover.domain.com ?

  • Perry,
    Yes, it’s set for autodiscover.domain.com, and it’s a CNAME pointed to the Exchange host. If your Exchange host supports autodiscovery domains, they should have instructions on how to set this up.

  • passion2u

    Hi Jason,
    Looks like I also faced a same problem. For your info, I just buy a domain and hosting from Justhost.com and today my domain alreay propogate. I would like to know how you resolved the prompt password hence I also experienced the same problem while log in to cPanel. My windows security keep repeatedly prompt for a passwords for every text and image it downloading. From the research I done in the web, some person stated that iy’s because of my windows7 and Kaspersky2010 problem, is it correct?

  • passion2u,
    I explained how I solved my problem in the post. I think the problem you’re having is completely different and I have no ideas as to how to solve it.